カスタマイズ · ユーザーインターフェイス · ガイド

Rhino 9のワークスペースをカスタマイズする

Rhino 9のUIを変更し、カスタムツールを作成して共有する

30分Windows / Mac版Rhino 9中級
Rhino 9のワークスペースをカスタマイズする

このチュートリアルでは、ビジュアライゼーションとプレゼンテーションを担当するチームを例に、Rhino 9のユーザーインターフェイスをカスタマイズする方法を説明します。このチュートリアルを通して、特定の分野に合わせてUIをさまざまな方法で設定できることを紹介し、よく使うツールに常にすぐアクセスできるようにします。最後に、カスタムUIを保存し、同僚やラボ全体、または複数のコンピューター間で共有する方法を説明します。

What you'll learn

  • 新しいアイコンの背後にあるロジックを理解する
  • Rhinoでホットキー(インスタントエイリアス)を作成する
  • 自分の作業方法に最適なコマンドラインのスタイルを見つける
  • アイコンとツールバーを作成する
  • ニーズに応じてパネルを配置・再配置する
  • 既存の表示モードを変更して、ビジュアルや雰囲気を微調整する
  • カスタムユーザーインターフェイスを共有する

新しいアイコンを理解する

Rhino 9のツールバーアイコンは、一貫したカラーコーディングシステムに基づいてデザインが変更されました。ツールはオブジェクトのタイプやタスクごとにグループ化されているため、ひと目で見分けやすくなっています。デザイン変更の背後にあるロジックについては、機能紹介ページで詳しく説明しています。

インスタントエイリアス(ホットキー)を作成する

エイリアスとは、Rhinoのコマンドやマクロを実行するように設定されたキーボードショートカットです。Rhino 8までは、エイリアスを実行するには文字をタイプした後にEnterキーを押す必要がありました。これは、長時間のモデリング作業では余分な手順となります。Rhino 9では、文字を入力し終えた瞬間に実行される インスタントエイリアス が導入されました。Enterを押す必要はありません。

それでは、ビューポート内をすばやく移動できるように、いくつかエイリアスを追加してみましょう。

  1. Rhinoオプション を開き、 エイリアス ページを開きます。
  2. ZE の インスタント をオンにして、 そのインスタントエイリアスを使用して Zoom 全体表示 を実行します。 Rhinoオプション
  3. インスタントエイリアスと同じ文字で始まる長いエイリアス、たとえば Zebra を実行する zea を入力してみてください。 ze がインスタントに設定されているため、zeaと入力し終える前にそちらが実行されてしまいます。このような場合、 Shift を押しながらタイプすると、インスタントエイリアスを回避することができます。
  4. ビューポートを最大化および最小化するための新しいインスタントエイリアスを追加します。
    1. 左上の + 新規作成 ボタンを 選択 します。
    2. エイリアス に、 Max と入力します。
    3. コマンドマクロ に ! _MaxViewport と入力します。
    4. 隣の インスタント チェックボックスを選択します。 Rhinoオプション
  5. OK をクリックします。
  6. いずれかのビューポートで max とタイプします。Enterを押さなくても、コマンドがすぐに実行されるのが分かります。エイリアスを実行するたびにビューポートが最大化・元のサイズに戻ります。
インスタントエイリアスと大文字・小文字
Rhinoのコマンドとエイリアスは大文字・小文字を区別しないため、ここでのShiftは純粋にインスタントエイリアスを回避するための修飾キーです。Shiftによって文字が大文字になることはありません。インスタントエイリアスに最初に設定するのにおすすめなのは、ビューの切り替え、選択フィルタ、その他1日に何度も使う1文字または2文字のショートカットです。

コマンドラインのスタイルを選ぶ

コマンドラインは常にRhinoの操作の中心でしたが、これまでWindowsとMacではまったく異なる操作体験が提供されてきました。Windowsはテキスト中心の履歴機能を重視する一方、Macはオプションをポップアップで表示するグラフィカルなサイドバーを採用していました。Rhino 9ではこれが統一され、すべてのコマンドラインスタイルが両方のプラットフォームで使えるようになりました。

それでは、コマンドラインを検索バーのようなシンプルなスタイルに変更してみましょう。

  1. CommandMode コマンドを実行します。

  2. 次のようにオプションを 選択 します:

    • 場所 を 別のパネル にします。
    • スタイル を ボタン にします。
    • Enterを押します。
  3. コマンドラインが別のコンテナに表示され、自由に移動できるようになりました。ビューポートの上に移動してフローティング表示にし、 Enter を押してコマンドを終了します。 CommandMode

  4. これでコマンドラインは表示されなくなりましたが、文字を入力し始めると表示されます。

    CommandMode

ツールバーをカスタマイズする

ツールバーとは、Rhinoのインターフェイス周辺に配置されている、クリックして操作できるアイコンのグループです。文字を入力してコマンドを実行する方法以外では、ほとんどの人にとって、コマンドを操作する主要な手段となっています。Rhino 9ではツールバーシステムが大幅に見直されました。従来の「diff」ファイルの仕組みは廃止され、完全な default.rui が復活し、ツールバーの編集はほぼすべて1つのダイアログで行えるようになりました。

ツールバーを作成する

よく使うツールや、新しく作成するツールを追加できるように、 My Viz Tools という名前のツールバーを作成してみましょう。

  1. Toolbar コマンドを実行して、統合されたツールバーダイアログを開き、次の操作を行います:

    1. ファイル → 新規RUI を選択します。
    2. 保存先のフォルダを選択します。
    3. ファイルに Project Viz と名前を付けます。
    4. 保存 をクリックします。
  2. これにより、 ツールバーコレクション が作成されました。

  3. ツールバーコレクションを編集するために、 Project Viz を ダブルクリック します。ここには、 My New Toolbar という1つのツールバーが含まれています。 新規ツールバー

  4. My New Toolbar を編集するために、ダブルクリックします。

  5. プロパティの下のツールバーの名前を My Viz Tools に変更します。 ツールバー検索と追加

  6. 右上の検索バーで特定のボタンを検索できます。目的のボタンが見つかったら、追加したいボタンをダブルクリックするか、 追加 の下にある + をクリックしてツールバーに追加します。まずは PerspectiveMatch を検索して、追加してみましょう。

    ツールバー検索と追加
  7. 次に、下のボタンを同様の手順で追加します:

  8. 編集 メニューを使うと、ツールバー項目を 元に戻す/やり直し、 コピー/カット/ペースト、または 削除 を行えるので、最初からやり直さなくても配置を変更できます。デフォルトで用意されている Hello! ボタンを選択し、 編集 メニューから 削除 を選んで削除しましょう。

    ツールバー編集メニュー
  9. ツールバーの編集が終わったら、 OK をクリックして、変更を保存します。

  10. 新しいツールバーをRhinoでフローティング表示するには、ツールバーのリストでツールバー名の前にある電球アイコンをクリックする必要があります。

    ツールバー表示フローティング

ツールバーアイコンを作成する

標準で搭載されているコマンドやボタンでは、希望する操作ができない場合があります。例えば、 ZoomExtents を使ってオブジェクトにズームしたいけれど、光源 オブジェクトは対象に含めたくない、というような場合です。この練習では、モデルの光源オブジェクトを無視して全体表示を行うボタンがある、新しいツールバーを作成します。

  1. ツールバーに新しいボタンを追加するには、次の2つの方法があります:

    • ツールバーエディタで、 編集 メニューから 新規ボタンを挿入 を選択します。新しいボタンが追加されたら、それを選択して、 編集 → ボタンを編集 を選択します。
    • Rhinoで My Viz Tools ツールバーを開いている場合は、それを右クリックして 新規ボタン… を選択します。 新規ツールバーボタン
  2. ボタンに Zoom No Lights という名前を付けます。名前 がすべての該当箇所に自動的に入力されます。 ツールバーの編集

  3. カスタムコマンドを追加するには、マクロを使用します。次の情報を コマンド セクションにタイプするか、コピーしてください: ! _SelNone _SelLight _Invert _Zoom _Selected _SelNone。

  4. ツールヒント には、自動的にコマンド名が入力されます。この例では、それを Zoom Extents Except Lights に変更します。

    ツールバーの編集
  5. 表示 の + 記号をクリックして、カスタムアイコンを追加します:

    1. 画像 を選択します。
    2. ライト の + 記号を選択します。
    3. SVGエディタでは、エディタ内のツールを使って、独自のアイコンを描くことができます。
  6. また、SVGファイルを読み込んで、ボタンのアイコンとして使用することもできます。

    1. Zoom-no-lights.svg をダウンロードします。
    2. ファイル → 開く を選択します。この例のアイコンを使用してください。
    ツールバーの編集
  7. ダークモードのアイコンをボタンに追加するには、 表示 → ダーク の + 記号をクリックします。ここで使用しているSVGファイルのダークモード版として、 zoom-no-lights_darkmode.svg をダウンロードしてください。

    カスタムツールバー

パネルを配置する

パネルを使うと、モデリングビューを離れることなく、「レイヤ」、「プロパティ」、「マテリアル」などの設定にすばやくアクセスできます。今回のビジュアライゼーション用UIでは、「光源」、「マテリアル」、「スナップショット」パネルを追加します。また、ツールにより速くアクセスできるように、2つのパネルを上下に重ねて配置します。

  1. パネルは、UIの右側にドッキングされたパネルの + タブをクリックして追加できます。リストで 光源 、 マテリアル 、そして スナップショット パネルに チェックマーク を入れます。デフォルトでオンになっている場合は、 表示 と レイアウト パネルのチェックマークは 外して ください。

    パネル
  2. レンダリング関連のタブがすべて隣り合うように、タブの順序を並べ替えます。タブをドラッグして新しい位置に移動してください。

    パネル
  3. スペースを節約するために、いくつかのパネルを移動してみましょう。 光源 パネルのタブをコンテナの外へドラッグして、独立したフローティングパネルウィンドウとして切り離します。

    パネルをフロートさせる
  4. 次に、 Lights パネルをドラッグして、ほかのパネルの下にドッキングします。ドッキングするには、タブではなくコンテナ部分をクリックしてドラッグする必要があるので注意してください。カーソルが4方向の矢印に変われば、正しい位置に置かれています。

    パネル
  5. マテリアル パネルのタブを選択して、 光源 パネルまで下方へドラッグします。

    パネルのタブ移動
  6. パネルのメニューボタンを選択して、タブを 水平 に切り替えます。

    パネル
コンテナが誤って動かないようにする
ドッキングされたコンテナをロック をオンにすると、モデリング中にパネルやツールバーがドラッグされて位置がずれるのを防げます。

表示モードに変更を加える

  1. Options コマンドを実行し、Rhinoオプションウィンドウで ビュー → 表示モード を開きます。

  2. コンセプト を選択し、 コピー をクリックします。

    表示モード
  3. コンセプトのコピー 表示モードを探し、名前を My Viz Display に変更します。

  4. 背景 を 4色グラデーション に変更し、次のように設定します:

    1. 上の色 - この色 #C5F6FA
    2. 下の色 - この色 #FFE8CC
    3. 左上の色 - この色 #C5F6FA
    4. 右上の色 - この色 #99E9F2
    5. 左下の色 - この色 #FFE8CC
    6. 右下の色 - この色 #FFD8A8
  5. シェーディング効果 を 平行線 に変更します。

    表示モード
  6. オブジェクト → 線 で、 シルエット を4にします。

  7. シルエット線 の色をやや明るめのダークカラー この色 #212529 に変更します。

    表示モード
  8. OK をクリックして、Rhinoオプションダイアログを閉じます。

  9. 表示モード を My Viz Display に変更します。

    表示モード

設定を移行する

次は、Rhinoの設定を別のコンピューターに移行する方法を見ていきましょう。移行できるものには、オプション設定、カスタマイズしたツールバー(RUI)、ウィンドウレイアウトなどがあります。この方法で、自分好みにカスタマイズしたRhinoの環境を、そのまま別のコンピューターに移すことができます。

OptionsMigrate コマンドを使用すると、個々の設定を一つずつ選んで移行するのではなく、Rhinoの環境一式を別のRhinoに一度に取り込むことができます。オプション設定、エイリアス、キーボードショートカット、プラグイン、スキーム、ウィンドウレイアウト、カスタムツールバーやRUIファイルなど、すべてを移行したい場合に使用します。

OptionsMigrate ** コマンドは、次の3つの場所から設定を取り込めます:**

  • このコンピューターにインストールされている以前のバージョンのRhino(例えば、Rhino 8の設定をRhino 9に移行する場合)。
  • 別のコンピューターで OptionsExport コマンドを使用してエクスポートした.rhs ファイル。WindowsとMac間も含め、コンピューター間で設定を移行するときはこの方法を使います。
  • Rhinoが作成したバックアップ。 Reset コマンドを実行したときに書き出されるバックアップも含まれます。

このコマンドは、 従来の OptionsImporter と PreviousOptionsImporter コマンドに代わるものです。これらは混同しやすく、すべての設定を取り込めるわけではありませんでした。

同じコンピューターで移行する

  1. OptionsMigrate コマンドを実行します。
  2. 移行元として、以前のバージョンのRhino、.rhsファイル、またはバックアップのいずれかを選択します。
  3. 終了 をクリックすると、Rhinoが設定一式を取り込みます。

Rhinoは置き換える前の設定を先にバックアップするため、現在の設定が失われることはありません。結果が思いどおりでなかった場合は、そのバックアップから元に戻すことができます。

別のコンピューターにエクスポートする

次に、Rhinoのすべての設定を別のコンピューターに移行してみましょう。Rhino 9では、すべての設定が .rhs という1種類のファイルにまとめられます。

  1. まず、現在のコンピューターのRhinoで OptionsExport コマンドを実行します。 OptionsExport は、 .rhs ウィンドウレイアウト、キーボードショートカット、エイリアス、プラグイン、スキーム、デフォルトおよびカスタムのRUI、高度な設定、ウィンドウの位置、そしてRhinoのオプションを含む.rhsファイルを作成します。ファイルをMy-viz-ui.rhsという名前で保存し、別のコンピューターに移動します。
  2. もう1つのコンピューターでは、 OptionsMigrate を使用して My-viz-ui.rhs ファイルを選択します。読み込まれた設定は、そのコンピューターの既存の設定と統合されます。
教室や新メンバーのために設定を揃えたいですか?
OptionsExport → OptionsMigrate の流れは、教室や新入社員に自分と同じRhinoの環境を用意する最も簡単な方法のひとつです。ツールバーを手作業で作り直す必要はまったくありません。

ウィンドウレイアウトを保存して共有する

すべての設定を移行するのではなく、ビジュアライゼーション用UIのツールバーとパネルの構成だけを別のコンピューターと共有したい場合は、ウィンドウレイアウトを使えば実現できます。

  1. ウィンドウ メニュー → ウィンドウレイアウト → ウィンドウレイアウトを保存… を選択し、My Viz UIと名前を付けます。

  2. ウィンドウ → ウィンドウレイアウト → ウィンドウレイアウトを管理… を選択すると、保存したレイアウトを確認できます。My Viz UIを選択し、 エクスポート ボタンをクリックします。ファイルをMy Viz UI.rhwという名前で保存します。

    パネル
  3. My Viz UI.rhwファイルを別のコンピューターに移動します。そのコンピューターで ウィンドウ → ウィンドウレイアウト → ウィンドウレイアウトを管理… を選択し、 インポート ボタンをクリックしてMy Viz UI.rhwを開きます。

    パネル
  4. RhinoでMy Viz UIを使うように切り替えるには、リストからMy Viz UIを選択し、復元 ボタンをクリックします。

    パネル
教室や新メンバーのために設定を揃えたいですか?
ウィンドウレイアウトは、同じコンピューターで使うのに最適です。レイアウトにはカスタムのRUIツールバーは含まれません。

Rhinoのコマンド

終了です!
おめでとうございます!これでこの練習は終了です。学習したツールを使ってデザインに詳細を加えるか、まったく新しいデザインを最初から作ってみてもいいでしょう。ご質問がある場合は、フォーラムまたはメールでサポートチーム(support@mcneel.com)までご連絡ください。