Personalizzazione · Interfaccia utente · Guida

Personalizzare l'area di lavoro di Rhino 9

Modifica l'interfaccia utente di Rhino 9, crea i tuoi strumenti personalizzati e condividili

30 minRhino 9 per Windows / MacIntermedio
Personalizzare l'area di lavoro di Rhino 9

In questo tutorial personalizzeremo l’interfaccia utente di Rhino 9 per un team concentrato su visualizzazione e presentazione. Nel corso della procedura vedrai i molti modi in cui l’interfaccia può essere rimodellata per adattarsi a una disciplina specifica, così gli strumenti che usi più spesso sono sempre a portata di mano. Infine vedremo come salvare l’interfaccia utente personalizzata e condividerla con i colleghi, in un laboratorio o tra i tuoi computer.

Cosa imparerai...

  • Comprendi la logica alla base delle nuove icone
  • Crea tasti di scelta rapida in Rhino, chiamati Alias immediati
  • Trova lo stile della linea di comando più adatto al tuo metodo di lavoro
  • Crea un’icona e una barra degli strumenti
  • Posiziona e riordina i pannelli in base alle tue esigenze
  • Modifica una modalità di visualizzazione esistente per perfezionare l’aspetto delle immagini
  • Condividi l’interfaccia utente personalizzata

Comprendere le nuove icone

Le icone della barra degli strumenti di Rhino 9 sono state ridisegnate sulla base di un sistema coerente di codifica a colori, che raggruppa gli strumenti per tipo di oggetto e attività affinché siano più facili da riconoscere a colpo d’occhio. Per saperne di più sulla logica alla base della riprogettazione, consulta la pagina delle funzionalità .

Creare Alias immediati (tasti di scelta rapida)

Un Alias è una scorciatoia da tastiera configurata per eseguire un comando o una macro di Rhino. Fino a Rhino 8, eseguire un alias significava digitarlo e poi premere Invio, un passaggio aggiuntivo che si accumula durante una lunga sessione di modellazione. Rhino 9 introduce gli Alias immediati, che vengono eseguiti non appena termini di digitare le lettere. Non è necessario premere Invio.

Aggiungiamo alcuni alias per aiutarti a muoverti più rapidamente nella vista.

  1. Apri Opzioni e vai alla pagina Alias.
  2. Attiva Alias immediato per ZE per eseguire Zoom estensione. RhinoOptions
  3. Prova a digitare un alias più lungo che inizi con le stesse lettere di uno dei tuoi Alias immediati, ad esempio zea per Zebra. Poiché ze è immediato, verrà eseguito prima che tu possa terminare di digitare. Tieni premuto Maiusc mentre digiti per ignorare gli alias immediati quando ti serve quello più lungo.
  4. Aggiungine uno nuovo per ingrandire e ridurre la vista:
    1. Seleziona il pulsante + Nuovo nell’angolo superiore sinistro.
    2. Per Alias, digita la scorciatoia Max.
    3. Per la Macro di comando, digita: ! _MaxViewport.
    4. Seleziona la casella di controllo Alias immediato accanto ad essa. RhinoOptions
  5. Premi OK.
  6. In una delle viste, digita max. Nota che il comando viene eseguito immediatamente, senza premere Invio, e che la vista viene ingrandita e ripristinata quando esegui l’alias.
Alias immediati e distinzione tra maiuscole e minuscole
I comandi e gli alias di Rhino non distinguono maiuscole e minuscole, quindi Maiusc serve esclusivamente come modificatore per ignorare l’esecuzione immediata. Non trasforma le lettere in maiuscole. Buoni candidati iniziali per gli alias immediati sono i cambi di vista, i filtri di selezione e altre scorciatoie di una o due lettere che usi decine di volte al giorno.

Scegliere lo stile della linea di comando

La linea di comando è sempre stata fondamentale per il funzionamento di Rhino, ma storicamente Windows e Mac hanno offerto esperienze molto diverse: Windows privilegiava una cronologia persistente ricca di testo, mentre Mac preferiva una barra laterale grafica con popup per le opzioni. Rhino 9 unifica questa esperienza e ora ogni stile della linea di comando è disponibile su entrambe le piattaforme.

Cambiamo la linea di comando per usare uno stile più semplice, simile a una barra di ricerca.

  1. Esegui il comando ModalitàComando .

  2. Seleziona :

    • Posizione = SeparatePanel
    • Stile = Buttons
    • Premi Invio.
  3. Ora la linea di comando si trova in un contenitore separato che puoi spostare. Spostala sopra la vista per renderla mobile, quindi premi Invio per terminare il comando. CommandMode

  4. Ora la linea di comando è scomparsa dall’interfaccia, ma se inizi a digitare verrà visualizzata.

    CommandMode

Personalizzare le barre degli strumenti

Le barre degli strumenti sono gruppi di icone cliccabili che circondano l’interfaccia di Rhino. Sono il modo principale con cui la maggior parte degli utenti interagisce con i comandi oltre alla digitazione. In Rhino 9, il sistema delle barre degli strumenti è stato profondamente rielaborato: il vecchio meccanismo dei file “diff” è scomparso, è tornato un file default.rui appropriato e quasi tutte le operazioni di modifica delle barre degli strumenti ora si svolgono in un’unica finestra di dialogo.

Creare una barra degli strumenti

Creiamo una barra degli strumenti chiamata My Viz Tools così possiamo aggiungere gli strumenti che usiamo più spesso e quelli nuovi che creiamo.

  1. Esegui il comando BarraStrumenti per aprire la finestra di dialogo consolidata Barra strumenti:

    1. Vai a File → Nuovo file RUI.
    2. Seleziona la cartella in cui vuoi salvarlo.
    3. Assegna al file il nome Project Viz.
    4. Premi Salva.
  2. Ora hai creato una Collezione delle barre degli strumenti.

  3. Per modificare la collezione delle barre degli strumenti, fai doppio clic su Project Viz. Contiene una barra degli strumenti: La mia nuova barra strumenti. ToolbarNew

  4. Fai di nuovo doppio clic per modificare La mia nuova barra strumenti.

  5. Cambia il nome della barra degli strumenti nelle Proprietà in My Viz Tools. ToolbarSearchAndAdd

  6. Puoi cercare pulsanti specifici nella barra di ricerca nell’angolo superiore destro; quando trovi quello che cerchi, fai doppio clic sul pulsante da aggiungere oppure premi il segno + sotto Aggiungi per aggiungerlo alla barra degli strumenti. Inizia cercando AdattaProspettiva e aggiungilo.

    ToolbarSearchAndAdd
  7. Aggiungi poi i seguenti pulsanti nello stesso modo:

  8. Dal menu Modifica, puoi annullare/ripristinare, copiare/tagliare/incollare o eliminare gli elementi della barra degli strumenti per riorganizzarli senza ricominciare da capo. Seleziona il pulsante predefinito Ciao!, quindi dal menu Modifica scegli Elimina.

    ToolbarEditMenu
  9. Quando hai finito di modificare la barra degli strumenti, premi OK per salvare le modifiche.

  10. Per fare apparire la nuova barra degli strumenti come mobile in Rhino, devi fare clic sull’icona a forma di lampadina davanti al nome della barra nell’elenco delle barre degli strumenti.

    ToolbarShowFloating

Creare un’icona della barra degli strumenti

A volte i comandi e i pulsanti standard non fanno esattamente ciò che desideri. Ad esempio, vogliamo usare ZoomEstensione per eseguire lo zoom sugli oggetti, ma non vogliamo che il comando consideri gli oggetti luce presenti nel modello. In questo esercizio creeremo una nuova barra degli strumenti con un pulsante che esegue Zoom estensione ignorando gli oggetti luce presenti nel modello.

  1. Per aggiungere un nuovo pulsante alla barra degli strumenti puoi procedere in due modi:

    • Nell’Editor della barra degli strumenti puoi premere il menu Modifica e scegliere Inserisci nuovo pulsante. Una volta aggiunto il nuovo pulsante, puoi selezionarlo e scegliere Modifica → Modifica pulsante.
    • Se la barra degli strumenti My Viz Tools è aperta in Rhino, puoi fare clic con il pulsante destro del mouse su di essa e scegliere Nuovo pulsante…. NewToolbarButton
  2. Aggiungi al pulsante il nome Zoom No Lights. Il campo Nome verrà compilato automaticamente in tutti i punti. ToolbarEdit

  3. Per aggiungere il comando personalizzato useremo una macro. Digita o copia quanto segue nella sezione Comando: ! _SelNone _SelLight _Invert _Zoom _Selected _SelNone.

  4. Il campo Descrizione comando verrà compilato automaticamente con il nome del comando. In questo esempio lo cambieremo in: Zoom Extents Except Lights

    ToolbarEdit
  5. Aggiungi un’icona personalizzata al pulsante premendo il segno + sotto Aspetto:

    1. Seleziona Immagine.
    2. Scegli il segno + sotto Chiaro.
    3. Nell’editor SVG puoi disegnare la tua icona usando gli strumenti di disegno dell’editor SVG stesso.
  6. In alternativa, puoi importare un file SVG da usare nel pulsante:

    1. Scarica zoom-no-lights.svg.
    2. Vai a File → Apri. Usa l’icona di questo esempio.
    ToolbarEdit
  7. Per aggiungere al pulsante un’icona per la modalità scura, premi il segno + sotto Aspetto → Scuro. Scarica zoom-no-lights_darkmode.svg per ottenere la versione in modalità scura del file SVG utilizzato.

    CustomToolbar

Disporre i pannelli

I pannelli ti danno accesso rapido a controlli come Livelli, Proprietà e Materiali senza lasciare la vista di modellazione. Per la nostra interfaccia utente di visualizzazione vogliamo aggiungere i pannelli Luci, Materiali e Istantanee. Vogliamo anche impilare due pannelli uno sopra l’altro per accedere più rapidamente agli strumenti.

  1. Puoi aggiungere un pannello facendo clic sulla scheda + nei pannelli ancorati a destra dell’interfaccia. Seleziona i pannelli Luci , Materiali e Istantanee dall’elenco. Deseleziona i pannelli Visualizzazione e Layout , se sono attivi per impostazione predefinita.

    Pannelli
  2. Riordina le schede in modo che tutti i pannelli relativi al rendering siano vicini tra loro. Per farlo, trascina la scheda in una nuova posizione.

    Pannelli
  3. Spostiamo alcuni pannelli per risparmiare spazio. Trascina il pannello Luci dalla scheda fuori dal contenitore per trasformarlo in una finestra di pannello mobile autonoma.

    PanelsFloating
  4. Ora ancora il pannello Luci sotto gli altri pannelli trascinandolo. Nota che devi fare clic sul contenitore, non sulla scheda, per ancorarlo. Quando il cursore cambia in quattro frecce, ti trovi nel punto giusto.

    Pannelli
  5. Seleziona la scheda del pannello Materiali e trascinala verso il basso, sul pannello Luci .

    PanelsMovetab
  6. Seleziona il pulsante del menu del pannello per passare a Orizzontale.

    Pannelli
Evita che i contenitori si spostino accidentalmente
Attiva Blocca contenitori ancorati per impedire che pannelli e barre degli strumenti vengano trascinati fuori posizione durante la modellazione.

Modificare la modalità di visualizzazione

  1. Esegui il comando Opzioni e, nella finestra Opzioni, vai a Vista → Modalità di visualizzazione.
  2. Seleziona Concettuale e premi Copia.
Modalità di visualizzazione
  1. Vai alla modalità di visualizzazione Copia di Concettuale e cambia il nome in My Viz Display:

  2. Cambia il Colore di sfondo in Gradient 4 Colors:

    1. Imposta il colore superiore questo colore su #C5F6FA.
    2. Imposta il colore inferiore questo colore su #FFE8CC.
    3. Imposta il colore superiore sinistro questo colore su #C5F6FA.
    4. Imposta il colore superiore destro questo colore su #99E9F2.
    5. Imposta il colore inferiore sinistro questo colore su #FFE8CC.
    6. Imposta il colore inferiore destro questo colore su #FFD8A8.
  3. Cambia l’Effetto di ombreggiatura in Linee parallele.

    Modalità di visualizzazione
  4. In Oggetto → Linee, aumenta Silhouette a 4.

  5. Modifica il Colore linee di silhouette in un nero più chiaro questo colore #212529.

    Modalità di visualizzazione
  6. Premi OK per chiudere la finestra di dialogo Opzioni.

  7. Cambia la modalità di visualizzazione in My Viz Display.

    Modalità di visualizzazione

Trasferire le impostazioni

Ora sposteremo le impostazioni di Rhino su un altro computer. Sono comprese: Opzioni, le barre degli strumenti personalizzate (RUI) e i Layout finestra. Tutto ciò che rende Rhino davvero tuo.

OpzioniDiMigrazione porta una configurazione completa di Rhino nell’installazione corrente di Rhino in un solo passaggio, invece di costringerti a scegliere tra singole impostazioni. Usalo quando vuoi trasferire tutto: Opzioni, alias, scorciatoie da tastiera, plugin, schemi, layout delle finestre e barre degli strumenti e RUI personalizzati.

OpzioniDiMigrazione può recuperare la configurazione da tre origini:

  • Una versione precedente di Rhino installata su questo computer (ad esempio, per trasferire la configurazione di Rhino 8 in Rhino 9).
  • Un file .rhs esportato da un altro computer con OpzioniDiEsportazione . È così che trasferisci la configurazione tra computer, inclusi Windows e Mac.
  • Un backup creato da Rhino, compreso quello scritto quando esegui Reimposta .

Sostituisce i comandi StrumentoImportazioneOpzioni e StrumentoImportazioneOpzioniPrecedenti precedenti, che erano facili da confondere e non acquisivano tutto.

Eseguire la migrazione sullo stesso computer

  1. Esegui OpzioniDiMigrazione .
  2. Scegli l’origine: una versione precedente di Rhino, un file .rhs o un backup.
  3. Premi Fine e Rhino importerà la configurazione completa.

Prima di sostituire qualsiasi elemento, Rhino crea un backup di ciò che verrà rimpiazzato, quindi la configurazione attuale non viene mai persa. Se il risultato non è quello desiderato, puoi eseguire nuovamente la migrazione da quel backup.

Esportare su un altro computer

Ora trasferiamo tutte le impostazioni di Rhino su un altro computer. Rhino 9 riunisce tutto in un unico tipo di file: .rhs.

  1. Su questo computer, esegui OpzioniDiEsportazione in Rhino. OpzioniDiEsportazione crea un file .rhs contenente Layout finestra, Abbreviazioni da tastiera, Alias, Plug-in, Schemi, RUI predefiniti e personalizzati, Impostazioni avanzate, Posizioni delle finestre e Opzioni di Rhino. Salva il file come My-viz-ui.rhs e trasferiscilo sull’altro computer.
  2. Sull’altro computer, usa OpzioniDiMigrazione e seleziona il file My-viz-ui.rhs. In questo modo le impostazioni in arrivo vengono unite a quelle già presenti.
Devi formare o inserire un team?
OpzioniDiEsportazione → OpzioniDiMigrazione è uno dei modi più semplici per fare in modo che un’aula o un nuovo membro del team utilizzi la stessa configurazione di Rhino, senza dover ricreare manualmente le barre degli strumenti.

Salvare e condividere i Layout finestra

Se vuoi condividere solo la configurazione di barre degli strumenti e pannelli della tua interfaccia Viz con un altro computer, anziché tutte le impostazioni come fa Impostazioni di trasferimento, i Layout finestra ti permetteranno di farlo.

  1. Vai al menu Finestra → Layout finestra → Salva layout finestra… e assegnagli il nome My Viz UI.

  2. Vai a Finestra → Layout finestra → Gestisci layout finestra… per visualizzare i layout salvati. Seleziona My Viz UI e premi il pulsante Esporta. Salva il file come My Viz UI.rhw.

    Pannelli
  3. Sposta il file My Viz UI.rhw sull’altro computer. Su quel computer, vai a Finestra → Layout finestra → Gestisci layout finestra…, quindi premi il pulsante Importa per aprire My Viz UI.rhw.

    Pannelli
  4. Per configurare Rhino in modo che usi My Viz UI, seleziona My Viz UI dall’elenco e premi il pulsante Ripristina.

    Pannelli
Devi formare o inserire un team?
I Layout finestra si usano al meglio sullo stesso computer. I layout non includono le barre degli strumenti RUI personalizzate.

Comandi di Rhino

Completato!
Congratulazioni per aver completato questo tutorial! Continuare a usare questi strumenti per dettagliare il progetto o per crearne uno nuovo da zero. Per domande, scrivici sul Discourse o invia un’e-mail al nostro team di supporto: support@mcneel.com.