Personalizar · Interfaz de usuario · Guía

Personalice su espacio de trabajo de Rhino 9

Modifique la interfaz de usuario de Rhino 9, cree sus herramientas personalizadas y compártalas

30 min.Rhino 9 para Windows / MacIntermedio
Personalice su espacio de trabajo de Rhino 9

En este tutorial, personalizaremos la interfaz de usuario de Rhino 9 para un equipo centrado en la visualización y la presentación. A lo largo del proceso, verá las numerosas formas en que se puede remodelar la interfaz de usuario para adaptarla a una disciplina específica, de modo que las herramientas que más utiliza estén siempre a su alcance. Por último, veremos cómo guardar su interfaz de usuario personalizada y compartirla con compañeros, en un aula o entre sus equipos.

Lo que aprenderá

  • Comprender la lógica detrás de los nuevos iconos
  • Crear teclas de acceso rápido en Rhino, denominados Alias instantáneos
  • Encontrar el estilo de la Línea de comandos que mejor se adapte a su método de trabajo
  • Crear un icono y una barra de herramientas
  • Colocar y reorganizar los paneles para adaptarlos a sus necesidades
  • Modificar un modo de visualización existente para ajustar el aspecto de sus elementos visuales
  • Compartir la interfaz de usuario personalizada

Comprender los nuevos iconos

Los iconos de la barra de herramientas de Rhino 9 se han rediseñado en torno a un sistema de codificación por colores coherente, que agrupan las herramientas por tipo de objeto y tarea para que sean más fáciles de reconocer de un vistazo. Obtenga más información sobre la lógica que subyace al rediseño en la página de la función.

Crear alias instantáneos (teclas de acceso rápido)

Un alias es un acceso directo de teclado configurado para ejecutar un comando o una macro de Rhino. Hasta Rhino 8, ejecutar un alias implicaba escribirlo y luego pulsar Intro, un paso adicional que se va acumulando a lo largo de una larga sesión de modelado. Rhino 9 presenta los Alias instantáneos, que se ejecutan en el momento en que termina de escribir las letras. No es necesario pulsar Intro.

Vamos a añadir algunos alias para ayudarle a moverse por vista con mayor rapidez.

  1. Abra Opciones y vaya a la página Alias.
  2. Active la opción Instantáneo para que ZE ejecute Extensión de zoom. Opciones de Rhino
  3. Intente escribir un alias más largo que empiece con las mismas letras que uno de sus alias instantáneos, como zea para Cebra. Como ze es instantáneo, se activará antes de que pueda terminar de escribir. Mantenga pulsada la tecla Mayús mientras escribe para omitir los alias instantáneos cuando necesite el más largo.
  4. Añada uno nuevo para maximizar y minimizar la vista:
    1. Seleccione el botón + Nuevo en la esquina superior izquierda.
    2. En Alias, escriba el acceso directo Max.
    3. Para la Macro de comando, escriba: ! _MaxViewport.
    4. Seleccione la casilla de verificación Instantáneo que hay junto a ella. Opciones de Rhino
  5. Pulse Aceptar.
  6. En una de las vistas, escriba max. Observe que el comando se ejecuta inmediatamente, sin necesidad de pulsar Intro, y que la vista se maximiza y se restaura cuando ejecuta el alias.
Alias instantáneos y mayúsculas y minúsculas
Los comandos y los alias en Rhino siempre han distinguido entre mayúsculas y minúsculas, por lo que la tecla Mayús aquí es simplemente un modificador para saltarse la regla. No pondrá nada en mayúscula. Buenos candidatos para alias instantáneos: cambios de vista, filtros de selección y otros accesos directos de una o dos letras que utiliza decenas de veces al día.

Elija su estilo de línea de comandos

La línea de comandos siempre ha sido fundamental para el funcionamiento de Rhino, pero Windows y Mac han ofrecido históricamente experiencias muy diferentes: Windows se basaba en un historial persistente y con mucho texto, mientras que Mac prefería una barra lateral gráfica con ventanas emergentes para las opciones. Rhino 9 lo unifica, y todos los estilos de línea de comandos están ahora disponibles en ambas plataformas.

Vamos a cambiar la línea de comandos para usar un estilo más sencillo, como una barra de búsqueda.

  1. Ejecute el comando ModoDeComando .

  2. Seleccione :

    • La Ubicación debe ser PanelSeparado
    • El Estilo debe ser Botones
    • Pulse Intro.
  3. La línea de comandos está ahora en un contenedor independiente que puede mover. Muévala a la parte superior de la vista para que se quede flotante y, a continuación, pulse Intro para finalizar el comando. ModoDeComando

  4. Ahora la línea de comandos ha desaparecido de la interfaz, pero si empieza a escribir, aparecerá.

    ModoDeComando

Personalizar las barras de herramientas

Las barras de herramientas son los grupos de iconos que rodean la interfaz de Rhino. Son la forma principal en que la mayoría de las personas interactúan con los comandos, además de escribirlos. En Rhino 9, el sistema de barras de herramientas se ha rediseñado sustancialmente: El antiguo mecanismo de archivos “diff” ha desaparecido, se ha recuperado el archivo default.rui y casi toda la edición de barras de herramientas se realiza ahora en un único cuadro de diálogo.

Crear una barra de herramientas

Vamos a crear una barra de herramientas llamada My Viz Tools para que podamos añadir nuestras herramientas más utilizadas, así como las nuevas herramientas que creemos.

  1. Ejecute el comando BarraDeHerramientas para abrir el cuadro de diálogo Barra de herramientas:

    1. Vaya a Archivo → Nuevo archivo RUI.
    2. Seleccione una carpeta en la que quiera guardarlo.
    3. Ponga al archivo el nombre Project Viz.
    4. Pulse Guardar.
  2. Ya ha creado un Grupo de barras de herramientas.

  3. Para editar el grupo de barras de herramientas, haga doble clic en Project Viz. Contiene una barra de herramientas: My New Toolbar. Nueva barra de herramientas

  4. Vuelva a hacer doble clic en ella para editar My New Toolbar.

  5. Cambie el nombre de su barra de herramientas en Propiedades a My Viz Tools. Buscar y añadir barra de herramientas

  6. Puede buscar botones específicos en la barra de búsqueda de la esquina superior derecha, y cuando encuentre el que busca, haga doble clic en el botón que desea añadir o pulse el signo + debajo de Añadir para añadirlo a su barra de herramientas. Para empezar, busque IgualaciónDePerspectiva y añádalo.

    Buscar y añadir barra de herramientas
  7. A continuación, añada los siguientes botones de la misma manera:

  8. En el menú Editar, puede deshacer/rehacer, copiar/cortar/pegar o eliminar elementos de la barra de herramientas para reorganizar las cosas sin tener que empezar de nuevo. Seleccione el botón predeterminado Hello! y, a continuación, en el menú Editar, elija Eliminar.

    Editar menú de barra de herramientas
  9. Cuando haya terminado de editar la barra de herramientas, pulse Aceptar para guardar los cambios.

  10. Para que la nueva barra de herramientas aparezca como flotante en Rhino, tiene que hacer clic en el icono de la bombilla que hay delante del nombre de la barra de herramientas en la lista de barras de herramientas.

    Mostrar barra de herramientas flotante

Crear un icono de barra de herramientas

A veces, los comandos y botones estándar no hacen exactamente lo que queremos. Por ejemplo, queremos usar ZoomExtensión para hacer zoom sobre los objetos, pero no queremos que el comando tenga en cuenta los objetos de luz. En este ejercicio, crearemos una nueva barra de herramientas con un botón que aplicará la Extensión de zoom ignorando cualquier objeto de luz del modelo.

  1. Para añadir un nuevo botón de barra de herramientas a su barra de herramientas, puede hacerlo de dos maneras:

    • En el Editor de barras de herramientas, puede pulsar el menú Editar y elegir Insertar nuevo botón. Una vez añadido el nuevo botón, puede seleccionarlo y elegir Editar → Editar botón.
    • Si tiene abierta la barra de herramientas My Viz Tools en Rhino, puede hacer clic con el botón derecho en ella y elegir Nuevo botón…. Nuevo botón de barra de herramientas
  2. Añada el nombre Zoom sin luces al botón. El Nombre se rellenará automáticamente en todos los lugares. Editar barra de herramientas

  3. Para añadir el comando personalizado, utilizaremos una macro. Escriba o copie lo siguiente en la sección Comando: ! _SelNone _SelLight _Invert _Zoom _Selected _SelNone.

  4. La Leyenda se rellenará automáticamente con el nombre del comando. En este ejemplo, lo cambiaremos a:Zoom Extensión excepto Luces.

    Editar barra de herramientas
  5. Añada un icono personalizado al botón pulsando el signo + en Apariencia:

    1. Seleccione Imagen.
    2. Seleccione el signo + en Luz.
    3. En el editor SVG, puede dibujar su propio icono utilizando las herramientas de dibujo del propio editor SVG.
  6. Como alternativa, puede importar un archivo SVG para utilizarlo en el botón:

    1. Descargue zoom-no-lights.svg.
    2. Vaya a Archivo → Abrir. Utilice el icono de este ejemplo.
    Editar barra de herramientas
  7. Para añadir un icono de modo oscuro a su botón, pulse el signo + en Apariencia → Oscuro. Descargue zoom-no-lights_darkmode.svg para obtener la versión en modo oscuro del archivo SVG utilizado.

    Barra de herramientas personalizada

Organizar los paneles

Los paneles permiten acceder rápidamente a controles como Capas, Propiedades y Materiales sin salir de la vista de modelado. Para nuestra interfaz de usuario de Visualización, queremos añadir los paneles Luces, Materiales e Instantáneas. También queremos tener dos paneles apilados uno encima del otro para acceder a las herramientas más rápidamente.

  1. Puede añadir un panel haciendo clic en la ficha + de los paneles acoplados a la derecha de la interfaz de usuario. Marque los paneles Luces , Materiales e Instantáneas en la lista. Desmarque los paneles Visualización y Diseños , si están activados de manera predeterminada.

    Paneles
  2. Reordene las pestañas para que todas las relacionadas con el renderizado estén juntas. Para ello, arrastre la pestaña a una nueva posición.

    Paneles
  3. Vamos a mover algunos de los paneles para ahorrar espacio. Arrastre el panel Luces de la ficha fuera de su contenedor para abrirlo en su propia ventana de panel flotante.

    Paneles flotantes
  4. Ahora, ancle el panel Luces debajo de los demás paneles arrastrándolo. Tenga en cuenta que debe hacer clic en el contenedor, no en la ficha, para poder acoplarlo. Cuando el cursor cambie a cuatro flechas, estará en el lugar correcto.

    Paneles
  5. Seleccione la pestaña del panel Materiales y arrástrela hacia abajo hasta el panel Luces .

    Ficha mover paneles
  6. Seleccione el botón del menú del panel para cambiar las pestañas a Horizontal.

    Paneles
Evitar que los contenedores se muevan accidentalmente
Active Bloquear contenedores acoplados para evitar que los paneles y las barras de herramientas se desplacen de su sitio mientras está modelando.

Modificar el modo de visualización

  1. Ejecute el comando Opciones y, en la ventana Opciones, vaya a Vista → Modos de visualización.

  2. Seleccione Conceptual y pulse Copiar.

    Modos de visualización
  3. Vaya a la Copia de Conceptual y cambie el nombre a My Viz Display:

  4. Cambie el Color de fondo a Degradado de 4 colores:

    1. Cambie el color superior a este color : #C5F6FA
    2. El color inferior, a este color : #FFE8CC
    3. El color superior izquierdo, a este color : #C5F6FA
    4. El color superior derecho, a este color : #99E9F2
    5. El color inferior izquierdo, a este color : #FFE8CC
    6. El color inferior derecho a este color : #FFD8A8
  5. Cambie el Efecto de sombreado a Líneas paralelas.

    Modos de visualización
  6. En Objeto → Líneas, aumente el valor de Silueta a 4.

  7. Modifique el color de la Línea de silueta a un tono oscuro más claro, a este color : #212529.

    Modos de visualización
  8. Pulse Aceptar para cerrar el cuadro de diálogo Opciones.

  9. Cambie el modo de visualización a My Viz Display.

    Modos de visualización

Transferir la configuración

A continuación, vamos a transferir la configuración de Rhino a otro equipo. Esto incluye: Opciones, barras de herramientas personalizadas (RUI) y los Diseños de ventana. Todo lo que hace que su Rhino sea único.

OpcionesMigrar transfiere una configuración completa de Rhino a su Rhino actual en un solo paso, en lugar de tener que seleccionar los ajustes uno por uno. Úsela cuando quiera mantenerlo todo: Opciones, alias, accesos directos de teclado, plugins, esquemas, diseños de ventana, barras de herramientas personalizadas y RUI.

OpcionesMigrar puede extraer esa configuración de tres lugares:

  • Una versión anterior de Rhino instalada en este equipo (por ejemplo, migrar su configuración de Rhino 8 a Rhino 9).
  • Un archivo .rhs exportado desde otro equipo con OpcionesExportar . Así es como puede transferir su configuración entre equipos, incluso entre Windows y Mac.
  • Una copia de seguridad creada por Rhino, incluida la que se genera al ejecutar Restablecer .

Reemplaza a los comandos anteriores ImportadorDeOpciones and ImportadorDeOpcionesAnterior que eran fáciles de confundir y no capturaban todos los datos.

Migrar en el mismo equipo

  1. Ejecute OpcionesMigrar .
  2. Elija el origen: Una versión anterior de Rhino, un archivo .rhs o una copia de seguridad.
  3. Pulse Finalizar y Rhino importará la configuración completa.

Rhino realiza una copia de seguridad de lo que vaya a reemplazar en primer lugar, por lo que nunca perderá su configuración actual. Si el resultado no es el que quería, puede volver a migrar desde esa copia de seguridad.

Exportar a otro equipo

A continuación, vamos a transferir toda su configuración de Rhino a otro equipo. Rhino 9 agrupa toda la configuración en un solo tipo de archivo: .rhs.

  1. En este equipo, ejecute OpcionesExportar en Rhino. OpcionesExportar crea un archivo .rhs que contiene sus diseños de ventanas, accesos directos de teclado, alias, plug-ins, esquemas, RUI predeterminados y personalizados, opciones avanzados, posiciones de ventanas y opciones de Rhino. Guarde el archivo como My-viz-ui.rhs y cópielo en el otro equipo.
  2. En el otro equipo, utilice OpcionesMigrar y seleccione el archivo My-viz-ui.rhs. Se fusionarán las opciones entrantes con las que ya están configuradas.
¿Está dando clases o enseñando a un equipo?
OpcionesExportar → OpcionesMigrar es una de las maneras más sencillas de conseguir que un aula o un nuevo empleado tengan la misma configuración de Rhino que usted, sin tener que reconstruir manualmente las barras de herramientas.

Guardar y compartir diseños de ventana

Si solo quiere compartir la configuración de barras de herramientas y paneles de su interfaz de usuario de visualización con otro equipo, en lugar de todas las opciones como lo hace Transferir configuración, la función Diseños de ventanas le permitirá hacerlo.

  1. Vaya al menú Ventana → Diseño de ventanas → Guardar diseño de ventana… y póngale el nombre My Viz UI.

  2. Vaya a Ventana → Diseños de ventana → Gestionar diseños de ventana… para ver sus diseños guardados. Seleccione My Viz UI y pulse el botón Exportar. Guarde el archivo como My Viz UI.rhw.

    Paneles
  3. Mueva el archivo My Viz UI.rhw al otro equipo. En ese equipo, vaya a Ventana → Diseños de ventana → Gestionar diseños de ventana… y, a continuación, pulse el botón Importar para abrir My Viz UI.rhw.

    Paneles
  4. Para actualizar Rhino para que use My Viz UI, seleccione My Viz UI en la lista y pulse el botón Restaurar.

    Paneles
¿Está dando clases o enseñando a un equipo?
Es recomendable utilizar los Diseños de ventanas en el mismo equipo. Los diseños no incluyen barras de herramientas RUI personalizadas.

Comandos de Rhino

Finalizado
¡Enhorabuena por completar este tutorial! No dude en seguir utilizando estas herramientas para detallar su diseño o crear uno nuevo desde cero. Si tiene alguna pregunta, puede escribir en Discourse o enviar un correo electrónico al equipo de soporte técnico: tech.eu@mcneel.com.